TP LINK M5 Deco Mesh issue

FarleyUKFarleyUK Frets: 887
Bit of a weird issue, and I'm not quite sure how to explain it, but here goes....

I've just started using three Deco M5 mesh things to increase the house Wi-Fi coverage. One of connected via ethernet to my router, and the others are all wireless to that.

One in the office upstairs has a NAS and a camera connected to it via it's ethernet ports.

I realised that the Mesh system created a new subnet (192.168.68.x). My router - and things connected via ethernet to it - are on 192.168.1.x. This means that I'm finding it hard to communicate with devices across subnets.

For example - I cannot remotely connect to Plex on the NAS as it's on a different subnet to the router. The cameras all connect and record to the NAS as they're on the same subnet.

Any ideas what I can do? I can put the Deco M5s into access point mode, but that means anything connected to them via ethernet (I.e. Cameras and NAS) are not accessible at all.

Anyone encountered this before? Am sure there's a simple answer!
0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter

Comments

  • GrumpyrockerGrumpyrocker Frets: 1516
    I think the simple solution would be to turn of DHCP on your router and stop using it for any device, just as your internet connection. This is what I do with our BT Home Hub - the Asus router I connect it to handles the DHCP and all devices connected to it.

    Then connect your base D5 to a cheap network switch that you can add those devices to. 

    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • TimmyOTimmyO Frets: 4022
    sounds like you only want one of the 2 parts of the system doing network management to avoid subnets - and yes that will mean that you need to hang any other stuff off of a part within the managed network (not off the 'dumb' device) 
    "Congratulations on being officially the most right anyone has ever been about anything, ever." -- Noisepolluter knows the score
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • TimmyOTimmyO Frets: 4022
    you probaby don't want your old router dishing out wifi anyway as it isn't part of the mesh network and devices might get 'stuck' on it when they'd be better hopping to a mesh point 
    "Congratulations on being officially the most right anyone has ever been about anything, ever." -- Noisepolluter knows the score
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FarleyUKFarleyUK Frets: 887
    Hmm.... if I disable DHCP on the router, the M5 base station isn't recognised at all. If I re-enable it, it works fine. If DHCP is off and I connect a laptop, that works fine; just the M5 that doesn't connect (not even showing as a connected device).

    I don't use the wifi on the router, so have disabled it.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • TimmyOTimmyO Frets: 4022
    Yeah something needs to be handing out IP addresses - can the mesh stuff not be told to do that? 
    "Congratulations on being officially the most right anyone has ever been about anything, ever." -- Noisepolluter knows the score
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FarleyUKFarleyUK Frets: 887
    TimmyO said:
    Yeah something needs to be handing out IP addresses - can the mesh stuff not be told to do that? 
    It assigns IP addresses to things connected to it - but the issue is that the Mesh device itself doesn't get given an IP address by the router if I disable DHCP on the router.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • GrumpyrockerGrumpyrocker Frets: 1516
    You should be able to manually assign it an email address. 

    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • SnagsSnags Frets: 1729
    Er, why is the Mesh device creating it's own subnet? If it's designed to provide true mesh wireless coverage for a LAN it should be fine sharing the same subnet. In fact it should be essential.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FarleyUKFarleyUK Frets: 887
    You should be able to manually assign it an email address. 
    Er... assign it an email address?

    Snags said:
    Er, why is the Mesh device creating it's own subnet? If it's designed to provide true mesh wireless coverage for a LAN it should be fine sharing the same subnet. In fact it should be essential.
    It has two modes - Router mode or Access Point mode. If it's in AP mode (so no subnet created), any device connected to a Mesh unit will not be recognised - which is no good for me, so I have to use it in router mode. I tested it with the router DHCP off and the M5 in AP mode - same problem happened with it not being recognised by the router as a connected device.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • dhaywood67dhaywood67 Frets: 49
    edited July 19
    A quick read on the support pages it intimates you can change both the LAN IP for the mesh router and the DHCP range. So, try restricting the DHCP range on your main router to around 50 addresses e.g. 192.168.1.10 to 192.168.1.50, Manually change the mesh router LAN IP to say 192.168.1.100 and set the DHCP range on the mesh router to assign addresses in the range 192.168.1.150 to 192.168.1.200

    I'm not guaranteeing this to work but it's what I'd try. You may still have an issue getting through the NAT on the mesh router though.

    As a side note it seems the 'user manual' available on the manufacturer's website doesn't actually detail all the available settings. It was only through looking at the FAQ for the difference between router and AP mode that I saw the options for the LAN IP and DHCP server.

    Also as someone previously stated you would expect AP mode to relay DHCP requests back to your main router. Very strange that it doesn't.

    Anyway hopefully the above may help with your issue?

    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FarleyUKFarleyUK Frets: 887
    A quick read on the support pages it intimates you can change both the LAN IP for the mesh router and the DHCP range. So, try restricting the DHCP range on your main router to around 50 addresses e.g. 192.168.1.10 to 192.168.1.50, Manually change the mesh router LAN IP to say 192.168.1.100 and set the DHCP range on the mesh router to assign addresses in the range 192.168.1.150 to 192.168.1.200

    I'm not guaranteeing this to work but it's what I'd try. You may still have an issue getting through the NAT on the mesh router though.

    As a side note it seems the 'user manual' available on the manufacturer's website doesn't actually detail all the available settings. It was only through looking at the FAQ for the difference between router and AP mode that I saw the options for the LAN IP and DHCP server.

    Also as someone previously stated you would expect AP mode to relay DHCP requests back to your main router. Very strange that it doesn't.

    Anyway hopefully the above may help with your issue?

    Thanks, will give that a try - much appreciated!
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • SnagsSnags Frets: 1729
    FarleyUK said:
    Snags said:
    Er, why is the Mesh device creating it's own subnet? If it's designed to provide true mesh wireless coverage for a LAN it should be fine sharing the same subnet. In fact it should be essential.
    It has two modes - Router mode or Access Point mode. If it's in AP mode (so no subnet created), any device connected to a Mesh unit will not be recognised - which is no good for me, so I have to use it in router mode. I tested it with the router DHCP off and the M5 in AP mode - same problem happened with it not being recognised by the router as a connected device.

    I'll go check the docs, but it sounds to me like it should be in AP mode, with DHCP enabled on your normal router.

    You definitely don't want the TP-Link acting as a router unless it's you're only router, otherwise you're effectively creating a Russian doll network, and it'll never work the way you want it to.

    Apologies if this is egg-sucking, but basically for a domestic network you should have one source of DHCP which is also ideally the local DNS server and router so that both DNS and NetBIOS lookups go through a single point of contact that manages the lot, otherwise you'll end up having to dick about with hosts files, or reserving IPs for everything and hard-coding them etc.

    If you introduce a second router you're basically ring-fencing anything "behind" it from the rest of the LAN unless it's a really, really proper router and fully configurable, and these most likely aren't.

    I'll away to look up the docs ...
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • SnagsSnags Frets: 1729
    Yup, looking at the user guide if you have it in router mode it expects to be the only router on your LAN.  So you either need to put your existing router into a modem-only mode so it passes through the Internet connection to the first Deco, or you need the Deco units in AP mode, and therefore acting as extenders/repeaters for your existing WiFi network.

    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FarleyUKFarleyUK Frets: 887
    Snags said:
    Yup, looking at the user guide if you have it in router mode it expects to be the only router on your LAN.  So you either need to put your existing router into a modem-only mode so it passes through the Internet connection to the first Deco, or you need the Deco units in AP mode, and therefore acting as extenders/repeaters for your existing WiFi network.

    Yep, understood; but the issue is then that - if they're in AP mode with DHCP on the main router - any device connected to the M5 units is no longer recognised and cannot be used.

    And as mentioned, if I disable the DHCP on the router, and have the M5 in router mode, the M5 connected to the main router isn't recognised.

    Apologies - my knowledge of networking is fairly limited!
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • SnagsSnags Frets: 1729
    FarleyUK said:
    Snags said:
    Yup, looking at the user guide if you have it in router mode it expects to be the only router on your LAN.  So you either need to put your existing router into a modem-only mode so it passes through the Internet connection to the first Deco, or you need the Deco units in AP mode, and therefore acting as extenders/repeaters for your existing WiFi network.

    Yep, understood; but the issue is then that - if they're in AP mode with DHCP on the main router - any device connected to the M5 units is no longer recognised and cannot be used.

    And as mentioned, if I disable the DHCP on the router, and have the M5 in router mode, the M5 connected to the main router isn't recognised.

    Apologies - my knowledge of networking is fairly limited!

    You want the first config, and the devices should be recognised if it's done right (helpful, eh?). It looks like you need to link your M5 into your existing wifi, rather than run its own SSID.

    Basically, it should all be integrated as one big system. If it isn't, you're going to have aggro. In essence, networking is really simple, but it can be a bugger to explain, and most people generally only have the lightbulb moment after going through a few pain sessions in different scenarios.

    Unfortunately I don't know the Deco devices (and I'm not mad keen on TP-Link in general, although it's often best-of-budget).

    What's your original router? If you can put that into a pass-through mode then you can use the Deco units with one as the router and the others as satellites (under no circumstances do you want all three acting as routers).
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • SnagsSnags Frets: 1729
    Sorry for double-post again, had a thought.

    Have you tried doing what it says in the FAQ here?

    That's what I would expect you to need to do in order to add the Deco devices as additional/improved wireless coverage to an existing network.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • GrumpyrockerGrumpyrocker Frets: 1516
    FarleyUK said:
    You should be able to manually assign it an email address. 
    Er... assign it an email address?

    Snags said:
    Er, why is the Mesh device creating it's own subnet? If it's designed to provide true mesh wireless coverage for a LAN it should be fine sharing the same subnet. In fact it should be essential.
    It has two modes - Router mode or Access Point mode. If it's in AP mode (so no subnet created), any device connected to a Mesh unit will not be recognised - which is no good for me, so I have to use it in router mode. I tested it with the router DHCP off and the M5 in AP mode - same problem happened with it not being recognised by the router as a connected device.
    Sorry, bloody phone autocorrected it.

    I meant IP Address.

    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FarleyUKFarleyUK Frets: 887
    Snags said:
    Sorry for double-post again, had a thought.

    Have you tried doing what it says in the FAQ here?

    That's what I would expect you to need to do in order to add the Deco devices as additional/improved wireless coverage to an existing network.
    Yep - tried that, but any devices connected to the Deco units are not registered or accessible.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • SnagsSnags Frets: 1729
    Hrm. Sounds like the Deco system isn't connecting into your router properly.

    Without physically being there, or having direct experience of the Deco, it's a bit tricky to know where to go.

    Based on reading around their site I would (and this may be what you've done):
    • put all three Deco into AP mode
    • run a patch lead from your normal router to the first Deco
    • use the Deco app to set a different SSID for the Deco system vs your router's WiFi
    • log into the router and look in the DHCP table to see if the first Deco AP has been assigned an IP address
    • check that there is nothing on the Deco units that is doing DHCP or doing anything other than being a WAP
    • with just the main Deco connected, try connecting to it wirelessly
    • if that works, bring the other Deco units in as repeaters (no physical connection back to router)
    I'd also be wanting to check that all of the Deco units are on the latest firmware, just in case.

    Beyond that for my little brain I'd need to be there in order to test things interactively and go delving into settings etc.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FarleyUKFarleyUK Frets: 887
    Cheers, will try that tomorrow when the Mrs is out....!
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FarleyUKFarleyUK Frets: 887
    Think I've cracked it.... no idea how!

    Put the M5 in router mode, disabled the DHCP on the main modem/router. Wasn't recognised, so set the M5 to a static IP, and it seems to be working now.

    PLEX on teh NAS is showing as accessible for remote access..... although i still cannot connect to the bloody service from outside my network. Grrrrrr.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • SnagsSnags Frets: 1729
    edited July 20
    You're halfway there,  but it's a bugger's muddle like that.  You need to configure your original router in bridging mode ideally, doing it the way you have. You also then need to do port forwarding for access from outside the LAN.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FarleyUKFarleyUK Frets: 887
    UPDATE - I've done it!

    After several attempts of pratting around - and ensurng Mrs Farley wouldn't be in - I put the Netgear router into modem only mode, and selected the Deco to be in Router (PPoE) mode. The steps I missed were assuming I needed to enter the broadband username etc. in the Netgear still - instead of in the Deco.

    All working now!
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • TimmyOTimmyO Frets: 4022
    Ahh good news - I'd been considering some mesh gubbins myself but this kind of put me off as it sounded like it wasn't working properly! 
    "Congratulations on being officially the most right anyone has ever been about anything, ever." -- Noisepolluter knows the score
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
Sign In or Register to comment.