Reaper newbie question: Lag on recording guitar vs the Spidf from the mixer

I'm recording from my ox box (Spdif) to Audio Interface (Presonus Frestudio Mobile) into my 2009 powerbook mac. 
The signal direct into the Universal Control mixer software sounds great. However, recording on Reaper, once the track is armed, this signal has a slight lag, making playing difficult with only the recorded track, or sounding odd if both the Spdif channel on the mixer and the Main mix of the audio from the computer (reaper or iTunes).
I assume the only way to fix this is to mute the track on Reaper whilst recording, allowing me to hear the other Reaper tracks. Is this correct? Then unmute when I want to hear the recording.
If this is correct, is there a way that tells Reaper to do this automatically (mute upon recording, unmute when playback)?

0reaction image LOL 0reaction image Wow! 0reaction image Wisdom

Comments

  • PolarityManPolarityMan Frets: 6262
    do you get the latency if you plug direct into the audio interface? my inclination would be to sort the latency out rather than faff around arming and un-arming the record monitroing on the tracks but reaper does have a monitoring option of "auto" which means it monitors only when the track is record armed. 
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom
  • lukedlblukedlb Frets: 460
    do you get the latency if you plug direct into the audio interface? my inclination would be to sort the latency out rather than faff around arming and un-arming the record monitroing on the tracks but reaper does have a monitoring option of "auto" which means it monitors only when the track is record armed. 
    You're probably right, polarityMan, although fixing it might require extra skills. The powerbook is from late 2008, 2.4 Ghz intel core 2 duo with an Ssd inside and only 4GB of ram. No doubt it should be enough for processing audio but maybe the reaper app is taxing it a little?
    The guitar signal coming from the Ox Box into the sound card and it sounds and plays great. Monitoring the track through reaper is the latency problem. Any thoughts on how to go about this?
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom
  • MusicwolfMusicwolf Frets: 2485
    Check the buffer size in ‘settings’ on Reaper.  Bigger buffer size = less chance of audio drop outs but also = greater latency.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom
  • Yep, buffer size experimantation will fix it. Don't forget to mute the signal outside of the DAW (on your UC mixing software). If you can get the latency down in reaper, you'll really start to enjoy the tracking process. If you can't, I highly recommend investing in a better PC/Mac... honestly, it's the best thing I've ever done, so rewarding when you hear your recordings the way you always imagined them.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom
  • lukedlblukedlb Frets: 460
    Yep, buffer size experimantation will fix it. Don't forget to mute the signal outside of the DAW (on your UC mixing software). If you can get the latency down in reaper, you'll really start to enjoy the tracking process. If you can't, I highly recommend investing in a better PC/Mac... honestly, it's the best thing I've ever done, so rewarding when you hear your recordings the way you always imagined them.
    I have a 2019 iMac. How can I connect a FireWire 400 to it? That would solve a whole lot of problems. 
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom
  • lukedlblukedlb Frets: 460
    Buffered it down to a low 200 and it has made a difference. Thank you @Jonathanthomas83 and @Musicwolf ;

    Getting a dongle to attach to the 400 (that's already going into an 800 dongle) would then require an 800 to thunderbolt 2 dongle and then another to thunderbolt 3. Apparently it should work. For the time being, I'll continue using my old MacBook Pro.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom
Sign In or Register to comment.